WordPress のタグプラグイン [ Simple Tag ] を 1.8 にアップグレードしたら PHP エラーが出た

スポンサードリンク

WordPress のタグプラグイン [ Simple Tag ] を 1.8 にアップグレードしたら、タグクラウド部分で PHP エラーが出るようになった。

タグクラウドを表示させる部分に、

<?php st_tag_cloud(); ?>

と言うコードを書いていたんだけど、[ Simple Tag ] を 1.8 にアップグレードしたら、

Fatal error: Call to undefined function taxonomy_exists()
in /wp-content/plugins/simple-tags/inc/client.php  on line 1699

みたいなエラーが出てタグクラウドが表示出来なくなった。

検索してエラーの回避法を見つけたんだけど、Simple Tags プラグインは以前も問題があったような気がするのと、プラグインのコードを弄るのは怖かったので、

<?php wp_tag_cloud('number=0'); ?>

と言う WordPress の標準コードに書き換えて様子をみることにした。

不具合が出ないんなら、Simple Tags プラグイン自体をアンインストールしようかな?

参考にさせてもらったページ

ありがとうございます。

WordPress プラグインに関するおすすめ書籍

WordPress プラグインに関しては、次の書籍がおすすめです!(^o^)

スポンサードリンク

この記事が気に入ったら、ぜひシェアをお願いします!

コメントを残す

メールアドレスが公開されることはありません。